HP Flex10 Issues – No Communication with Onboard Administrator

This is more an information post if anybody happens to come across a similar issue…  while doing some extensive testing on our new HP C7000 Blade setup, running 10GbE Flex10 modules we came across an issue where the Flex10 modules started playing up and would not load the config, resulting in all network connections connected to the effected switches to go down.

When logging into the HP Virtual Connect Manager it came up with a few issues with the domain, including:

  • The external links from the chassis were showing no link
  • No Communication error on the Domain Status page.  Stating: The Virtual Connect Manager is unable to communicate with the Onboard Administrator. Please ensure the module has an IP address.
  • Cross Link/Stacking links showing as down in some instances

In some instances it was not even possible to bring up the Virtual Connect Manager, it just sat on a loading page for an extensive period of time.  Running the vcutil health check would show random errors such as the following:

vcutil.ex e -a healthcheck -i XXXXXX -u Administrator -p XXXXXX

Domain Configuration: Not In Sync
Module Configuration: Not In Sync
Module Configuration: Invalid

Taking a supportdump using the vcutil package would show errors such as the following:

Saving Virtual Connect Support Information…Error
Could not get Primary VCM IP Address from Bay 1

This problem is solved by removing the DNS servers listed in “Enclosure Bay IP Addressing” for the Flex10 modules, and then rebooting them.

After solving this problem with the help of HP support, I was pointed to this article which seems to describe this exact problem: http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02720395&lang=en&cc=us&taskId=101&prodSeriesId=3794423&prodTypeId=3709945

I hope this saves someone facing the issue a bit of time resolving the issue!





  • Renaud

    Dear Aaron,
    Thanks for the post. We are facing this issue after an OA upgrade. VC is showing “no comm…”. We have another strange behavior: when I change the DNS under “Enclosure bay IP addressing” > “Interconnect Bays” and click apply it tells me ok. But when I come back on the page IPs for DNS are still here!! And no way to remove them. Is it the correct place to change those IPs?
    And another Question: when you mean reboot flex10 module, you mean loosing connection on one module? In the KB they say to “Reset virtual connect manager”: can we do it without impact? It’s just the management, correct?

  • Hi Renaud,

    I’ve heard this could be an issue, but not sure on an exact fix. It might be worthwhile waiting a little while to see if it picks up the change. I believe the Enclosure bay IP addressing assigns out IPs via DHCP. It sounds like you are adjusting the IP address in the correct spot.

    If you are still having issues, it may be a good idea to contact HP support. When I rebooted I did it via the OA, and just clicked on the Flex10 modules and rebooted them this way.

    Hope this helps!


  • Anne Laurent

    Our website is down for more than 5 hours now and no one is contacting us regarding this issue. Crucialp.com and Crucialparadigm.com are both down so all of the US customers are now affected, and there is no way for us to contact the support team.

    Could you please intervene and fix this issue and let us know what is going on?

    Thank you very much Aaron.

    Kind regards,

  • Anne Laurent

    The websites are all back on, thank you Aaron!

    Kind regards,

  • BJ

    Thanks! This solved the issue connecting to VC after running a firmware upgrade from 3.15 to 3.60. Two of my six interconnect modules upgraded then the last 4 failed. I had the same error “Could not get Primary VCM IP Address” in my logs which is how I found this.

  • HI BJ,

    Glad this helped solve your problem!